wordpress_good_bad

Bir pesimistin WordPress deneyimleri. Biraz bardağın boş tarafı biraz da deneyim.

  1. WordPress kullanmanın en ciddi dez avantajı muhtemel güvenlik açıkları ile karşılaşma riskinizin yüksek olmasıdır. Bu risk WordPress’in dünyada kullanılan en popüler içerik yönetim sistemlerinden biri olmasından kaynaklanır (CMS – Content Management System)
  2. WordPress varsayılan olarak içerik sayfalarına numaralandırılmış kalıcı bağlantılar verir ve çoğu kullanıcı bunu kategorisel ve anlamlı URL adreslerine dönüştürmenin başarısından habersizdir. Bu kötü bir özelliktir.
  3. WordPress’in geliştiricileri son kullanıcıya herhangi bir destek hizmeti sunmuyor. Son kullanıcı bu ihtiyacını topluluğun forum ve e-posta listelerinden karşılamak zorunda kalırken, nadiren de olsa  çeşitli destek talebi ve sorularında da yanıtsız kaldığını görebilirsiniz.
  4. WordPress eklentileri daha çok amatör kullanım içindir ve profesyonel geliştiricilerin ihtiyacını gidermez. Bu sorun özellikle özgün temanız ile mevcut eklentileri entegre etmeye çalışırken karşınıza çıkar.
  5. Çok da standart olmayan eklenti kodlarını inceleyip anlamak  zaman israfına neden olabilir. Eklentilerin çoğu tamamen ücretsizdir fakat doğru eklentiyi bulmak bazen çok fazla zamanınızı alabilir. Durum böyleyken birçok eklentinin de yıllarca güncellenmediğini ve herhangi bir destek verilmediğine de şahit olabilirsiniz.  Tam da doğru eklentiyi bulduğunuzu düşündüğünüzde eklentinin sitenin diğer fonksiyonlarına bağlı olarak sitenin aniden istenildiği gibi çalışmamasına, sitenin normal işleyişini olumsuz etkilemeye ve hatta tarayıcı uyumsuzluklarının oluşmasına da neden olabilir.
  6. WordPress inanılmaz derecede eski sürümlerine uyumluluk sağlar. Bu iyi bir özellik gibi gözükse de WordPress’in programlandığı dil olan PHP’nin modern özelliklerinin kullanılmasını kısıtlamıştır.
  7. Performans. Kod satırı yüksek bir tema ve çok sayıda eklenti kullanıyorsanız WordPress süpriz derecede yüksek bellek ve CPU kaynağına gereksinim duyduğuna kısa sürede şahit olursunuz. Bu noktada önbellek (cache) eklentisi veya web sunucu önbelleklemesi kullanma zorunluluğu ortaya çıkar.
  8. Sizin belirtecekleriniz…

 

2 YORUMLAR

  1. Söylediklerinize aynen katılıyorum ve 6. maddeye ekleme yapmak istiyorum. WordPress’in yalnızca PHP 7 ve üstlerinde çalışan bir sürüm çıkarması gerekiyor. Sırf eski sürümlerde çalışsın diye performanstan ve yeniliklerden yoksun kalınıyor. Bu yüzden PHP 7 ile gelen yeni özelliklere uygun olarak yeniden yazılması gerektiğini düşünüyorum.

    • Kesinlikle katılıyorum. Böyle bir durumda WordPress geliştirici ekibinin ikiye bölünmesi gerekecek. Benzer olarak PHP 10 (köklü değişiklikler) çıktığında da aynı şey olacak. Bu kullanıcılar açısından iyi geliştirici ekibi açısından fazladan mesai gerektirecek bir durum. Aynı handikapla eklenti ve tema geliştiricilerinin de karşı karşıya kalması söz konusu.

CEVAP VER